Ubuntu --color=auto aliases are horrible defaults

ubuntu

#1

First post… it is mostly a gripe… maybe it is a general Bash issue, but I experience it under Ubuntu.

I find the default of aliasing several commands to have ‘–color=auto’ terrible. Some texts are dark blue or dark red on black background - pretty much unreadable. How was this figured to work?

While it is easy enough for me to comment away those aliases in .bashrc, is there something to be done to the color scheme to make auto-coloring work (not too dark text on black background)?


#2

Welcome to nixCraft.

Defaults can be changed. What I do is I set terminal color via profile as per my needs. Usually dark black or solaris themes are great. Open gnome-terminal app. Click on the Edit > Preferences. You can either create a new profile or edit the default unnamed one:


Now adjust it as per your need and test it. Once set you are good to go.