Ssh: connect to host linux-server port 22: No route to host

Hi,

When my Ubuntu laptop wake up from sleep I always get this error or message:

ssh: connect to host linux-server port 22: No route to host

How to I fix it? It take some times up to 2 minutes to get rid of this problem. Internet also stop working and will only activate LAN and Internet after some RANDOM delay. Is there any delay settings for Ubuntu Linux that causing this problem?

I don’t think so dealy is part of any network settings. It might be an issue with the kernel driver that is not working correctly when waking from a sleep state.

Second, are you using bridged networking? Can you post the output of the following commands?

ip a s 
ip r s

No, I am not using bridge networking. It is simple set up on Dell laptop.

Did you noticed any errors or warning when wake up from sleep in your log files? To view those with the following command:

dmesg
dmesg | egrep 'error|warning'

Linux sysadmin blog - Linux/Unix Howtos and Tutorials - Linux bash shell scripting wiki