Set SELinux error messages in English but user desktop to Italian language version

Hi all,
I use Fedora in Italian, and when selinux sends a message, it is of course, in Italian. The problem is that it is not possible to understand what these messages mean! That’s not Italian.
So, my question: can I keep the OS in Italian and install/setup selinux in English?

You need to open Language support and set system-wide to English. You must be sysadmin level to do as follows (also install additional languages using this tool):

Per user settings

Reboot the system.

  1. Once done log in as normal user and open the Settings and Region & Language.
  2. Click Language.
  3. Select your desired region and language.
  4. Click Select to save.
  5. Your session needs to be restarted for changes to take effect. Either click Restart…, or manually log back in later.

Now system default is English but per user lang is as per above settings. To see the default settings, run:

localectl status

To see your current language support for user run:

locale

You can also view per user settings using the following file

sudo cat /var/lib/AccountsService/users/vivek

This for Marathi language for user named vivek as per above GUI settings:

[User]
Language=mr
Session=
FormatsLocale=mr_IN.UTF-8
XSession=
Icon=/home/vivek/.face
SystemAccount=false

[InputSource0]
xkb=us

The default system lang is defined in /etc/locale.gen for Debian/Ubuntu and /etc/locale.conf for RHEL/Fedora/CentOS Linux.

For global changes

Edit the /etc/locale.conf on Fedora or Red Hat Linux.

# set to english and this will help with SELinux
LANG=en_US.UTF-8

For particular user

Edit file ~/.bash_profile file and set:

export LANG="<your-lang-selection-here>"
# Set Italian i.e.  it_IT.UTF-8 
# Russian for example, use the 'locale -a' command get a list 
export LANG="ru_RU.UTF-8"
# Italian example
export LANG="it_IT.UTF-8"

Restart the session.


Linux sysadmin blog - Linux/Unix Howtos and Tutorials - Linux bash shell scripting wiki