Linux bridge vlan_filter - loose connection on native vlan (pvid)

Hi,

I’m setting up linux bridges to use with qemu/libvirt VMs on Fedora 36. Separating each vlan on a different bridge works fine:

nmcli con add type bridge con-name br0 ifname br0 ip4 192.168.1.16/24 gw4 192.168.1.1 ipv4.dns 192.168.1.253
nmcli con add type bond con-name bond0 ifname bond0 bond.options “mode=active-backup,miimon=100” ipv4.method disabled ipv6.method disabled master br0 slave-type bridge
nmcli con add type ethernet con-name enp1s0 ifname enp1s0 master bond0 slave-type bond
nmcli con add type ethernet con-name enp2s0 ifname enp2s0 master bond0 slave-type bond

nmcli con add type bridge con-name br2 ifname br2 ip4 192.168.2.16/24
nmcli con add type vlan con-name bond0.2 dev bond0 id 2 master br2 slave-type bridge

nmcli con add type bridge con-name br3 ifname br3 ip4 192.168.3.16/24
nmcli con add type vlan con-name bond0.3 dev bond0 id 3 master br3 slave-type bridge

But i would like to use vlan_filter, in order to pass for example a trunk interface (several tagged vlans in one interface) inside a VM. So, i tried like this:

nmcli con add type bridge con-name br0 ifname br0 ip4 192.168.1.16/24 gw4 192.168.1.1 ipv4.dns 192.168.1.253 bridge.vlan-filtering yes bridge.vlan-default-pvid 1 bridge.vlans “1-3”
nmcli con add type bond con-name bond0 ifname bond0 bond.options “mode=active-backup,miimon=100” ipv4.method disabled ipv6.method disabled master br0 slave-type bridge
nmcli con add type ethernet con-name enp1s0 ifname enp1s0 master bond0 slave-type bond
nmcli con add type ethernet con-name enp2s0 ifname enp2s0 master bond0 slave-type bond

Unfortunately, i loose connection with box as soon as i do this configuration, seems for some reason the native vlan (pvid) is not working.

Anyone has any idea what might be wrong?