I've got 99 addresses, but a CIDR ain't one

vpc
4glte
aws
cloudcomputing
#1

Ladies, Gentlemen, and friends of other identities,

Is it possible to force an IPv4 Address when your hot spot is only giving an IPv6?

Here’s the set up:

I work from home, hotels, hospitals, etc. When I am on an untrusted network, I fire up my trusty 4G-LTE hotspot and get to work. Every time before today, I received an IPv4 address (typically in the range of 172.55.1.1/16). Today I received an IPv6 address.

This causes problems because AWS doesn’t allow me to add an IPv6 address to our security groups, since the VPC (virtual private cloud) was established with IPv4 only. The obvious solution is to recreate the VPC with IPv6 addressing, but that is simply not an option for a “live” system.

So, until I can figure out how to force Verizon to give me an IPv4 address, I get one by being lucky, or I can figure out how to translate my IPv6 into an IPv4, I’m stuck working only from the Office.

Any thoughts?

#2

I can login to my ISP’s 4G router/hotspot and turn off IPv6 address. It has 3 options:

  1. IPv4 only
  2. IPv6 only
  3. IPv4/IPv6 (automatic)

Maybe you can find such option too?

#3

Quick answer would be to set up an IPv6 VPN somewhere and route your traffic back to your AWS instance over IPV4. Might require some tuning since you don’t want to tunnel a VPN inside of another one, but cascading two VPN links should be possible.

1 Like
#4

Multiple times and I have not found that option. :frowning:

#5

That’s a beautiful idea. I’ll push to implement that on both the Dev and Production networks.

Thanks!