Is anyone familiar with how to set up NVIDIA PRIME sync on a Ryzen 5 3550H laptop

The issue is the following. I’m currently running Manjaro 20.0.1 with GNOME. And I installed the hybrid driver for NVIDIA 1050TI which would be 440.82. mhwd did setup PRIME properly and I am able to run apps with the 1050TI but I experience severe tearing in all games.
The nvidia_drm module is active and all fine but PRIME Synchronization is not running. I tried setting it on xrandr with xrandr "display" --output --set "PRIME Synchronization" 1 but it fails and games continue to tear.

I am quite unsure how to manually set this up since the iGPU is a Ryzen 8 and most configurations are for intel. Even documentations are geared towards intel of course.

Here is the output of my xrandr --listproviders:
xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x55 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4
outputs: 2 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0
Provider 1: id: 0x1f7 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0

Edit:
nvidia-smi also works fine and detects the external GPU.

I spent lots of time with such drivers too. Only Intel and Nvidia worked and that too crashed some times. Finally, I went to bios disabled Intel GPU and only using dedicated as working from home so not worried about running out of battery juice. if you found working solution let me know.

1 Like

Would’ve done the same but my bios does not support switching GPUs so I’m kinda stuck with trying to configure Prime.

And sorry for the late reply. But I did find a working solution. It works with Prime offloading so performance is a bit cut down but battery life is superb.

The way I set it up was on Manjaro since there are pre-packaged configs for intel/nvidia or amd/nvidia.

The premise is simple. Using the built in mhwd tool, you install the video-hybrid-amd-nvidia-440xx-prime or respectively the intel driver and reboot. Works out of the box. No need to setup sync or anything of the sort. Just bear in mind that GNOME had tearing issues so I went over to XFCE to get rid of that issue.

I can now simply specify prime-run and everything works as it should.

If you’re interested to read more on this, here is the manjaro forum link for it:
manjaro-forum-link


Linux sysadmin blog - Linux/Unix Howtos and Tutorials - Linux bash shell scripting wiki