IPMI Supermicro -SOLVED


#1

STATUS: SOLVED.
I keep the post contents how I solved it if someone else has trouble with Supermicro server IPMI.

Update to my original post below:

I managed at least to get the webinterface. dont know why it never used to work as I set the correct static Host and Gateway addresses in the IPMI configuration in the BIOS. That settles my original post:

The Problem now becomes as follows:
Now that I have the webinterface in my browser, unfortunately the default username and password doesnt work. It is supposed to be admin/admin, so I need to reset the username/password.
A web search resulted in

ipmitool -I open user set password 2 ADMIN

as the solution from a runnin linux distro pn the machine. I have done so, but executig

ipmitool raw 0x3c 0x40

Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory
ng that I get

or executing

ipmitool -I open user set password 2 ADMIN

Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory

I then found the correct devices to load
Doing …

modprobe ipmi_devintf
modprobe ipmi_si

and then 
`ipmitool -I open user set password 2 ADMIN`
didnt give me an error message neither did it change admin admin as username and passw when I tried it.

I then tried.
ipmitool raw 0x3c 0x40

and this time also no error message, but it hard hanged the web interface and changed the bios ipmi information.
So I reconfigured gateway and hostname etc. and rebooted. Got the interface back but still the username password did not default to ADMIN/ADMIN

So that is where I got stuck.

It was only after several 
ipmitool raw 0x3c 0x40    then reboot then repeat 

and then finally performing a 

`ipmitool -I open user set password 2 ADMIN`

that the username and password defaulted to ADMIN ADMIN.
So now it works.


Original Post - Not relevant anymore.
=======================================================
I am trying to get IPMI to work to KVM over LAN support on my 24-core Supermicro servers. These do basically only numerical programs and need to be remotely accessed from time to time. The OS on all of them is Linux although that doesnt matter for IPMI issues, but I mention it anyway.I would mean "Remote" as on the internal LAN and not WAN.

I fail to get IPMI  running as there is no documetation I could find from Supermicro about what the default IP address is or how to set it. The board these servers use are  "http://www.supermicro.com/aplus/motherboard/opteron6000/sr56x0/H8DGU-F.cfm"
These have a dedicated IPMI port which is supposed to be the Ethernet port above the mouse and keyboard PS2 connectors. However I cannot connect to it through DHCP from a laptop, as it seemingly is neither a server or a client and seemingly must be configured as such.

It seems that dedicated IPMI firmware needs to be installed if you look at the links on the URL I listed. I dont want to just install firmware if I dont know it will brick the server, so I rather ask before I flash that. I am not sure if the IPMI firmware flashes independently from the BIOS firmware. I guess I have to make sure I flash the bios to the latest and then do the IPMI firmware flash, but I am not sure as I get no documentation on the procedure from Supermicro.
The Flash readme for IPMI mentions creating a floppy drive ... Jeeez! Some people refuse to advance. 

Anyone have these servers running on IPMI and can give me some pointers. It seems the documentation is sparse although this is not such  old servers.

Thanks