Install ASUS AC56-USB RTL8812AU Driver on Fedora Linux

Hi,

I am trying to get up and running with Fedora but having trouble installing my wireless adapter, an ASUS AC56-USB.
I have downloaded the drivers from ASUS but had zero success so far.

The system does recognise it is plugged in:
Bus 003 Device 002: ID 0b05:17d2 ASUSTek Computer, Inc. USB-AC56 802.11a/b/g/n/ac Wireless Adapter [Realtek RTL8812AU]

But I have nothing to indicate any wireless functionality.
I am hoping somebody with Fedora has managed to get one of these working and as I am quite new to Linux, any help will be very appreciated, thank you.

What do you see in GUI wifi app? Do you see Wi-Fi option along with visible networks?

In the GUI (fedora) I see only the option for a wired connection (not possible in this case) and to create a vpn. There is absolutely nothing for WiFi. Sort of like in Windows if the drivers were not installed.

Right. You need a driver with dkms. See this page https://tutorialforlinux.com/2020/01/14/step-by-step-fedora-31-realtek-rtl8812au-driver-installation-guide/

That is amazing thank you, I will go and try this now and get back to you, thank you so much!

Worked a treat thank you again!

@m1982j you are welcome. Glad it worked out.

Hi again,

I had to reinstall Fedora so I followed the guide again, i know it seems crazy as the exact same steps were took so it should just work, but instead I am getting this error:

[me@localhost rtl8812au-master]$ make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.3.7-301.fc31.x86_64/build M=/tmp/rtl8812au-master modules
make[1]: *** /lib/modules/5.3.7-301.fc31.x86_64/build: No such file or directory. Stop.
make: *** [Makefile:1068: modules] Error 2

I have ran the following:
sudo dnf install @development-tools kernel-headers kernel-devel elfutils-libelf-devel dkms

And I have downloaded and extracted the file to the /tmp folder.

I’m hoping there is something easy to fix here, thank you.

Try following steps again. Some times update kernel version may prevent compilation

I tried again and got same error, also did a clean install to try again and the same.

Could it be to do with the kernel version? if so is there a way to downgrade so it works?
just spit-balling as I have no idea about installing hardware on Linux.

Thanks again.


Linux sysadmin blog - Linux/Unix Howtos and Tutorials - Linux bash shell scripting wiki