How to read a hard drive out of Synology RAID 1 on my Ubuntu Linux computer

raid
data-recovery
synology
linux
macos
#1

Hi everyone,
I have a Synology DS214 NAS with 2 HDD of 2To as RAID 1 in it. This week my house was struck by lightning and it looks like the LAN card from the NAS went down. There is no light when I plug a cable and the LAN indicator in front of the NAS also stay off. Beside that, I can hear the HDD, stop and start the NAS from the power button and all the other leds are blinking.
But now I don’t know how to access my data. I tried to plug one of the hard drive in an USB external drive plugged to my Mac but it says he can’t read it. I believed that RAID 1 was a simple mirror and one disk could be used alone but maybe I’m missing something. I send a message to synology to see if the LAN card can be repaired.
Do you guys have other solutions ?
Thank you a lot for your replies :slight_smile:

#2

You can read data on Linux based machine. macOS won’t read Linux disk. The is the case of software raid in Linux. You need Linux based system. If you got Linux based system you can recover the data provided that hard disk wasn’t damaged too. This is also a good time to remember that RAID is not a backup solution.

#3

I was thinking about that but what tricks me is that I believed my Mac should have told me “those are ext4 partitions, I can’t read” and not “This hard drive has to be initialized”.
I will download virtualbox and an ubuntu image but while doing that I installed an ext tool on my windows. I plugged both drives as USB and what’s weird is I can now access an ext4 and a swap partition but the ext4 only shows the NAS OS files, the “Volume1” folder that should contains my data is empty.
The details of the partition is 1.58Go free of 2.37Go which is too low regarding the data I had on it I think. Do you think I will be able to access something else with a linux distro ? like another parition to mount or something like that ?
Thank you for your reply :slight_smile:

#4

Here is a screenshot of the ext2fsd interface:

Capture

humm maybe the RAW thing should be the user data partition, so two things: it’s lost or it’s a FS not handled by the software.

#5

If you click on yes, then your data lost in mac. Synology uses standard Linux md1/raid1/ext4. From the image it seems that you already lost the data. However, when you connect to Linux, you need to assemble RAID drive. Try pure Ubuntu based live cd, connect it via USB and assemble the raid 1.

#6

Of course I didn’t answer yes. I don’t understand how the os files are available but not the data.

#7

Try pure Ubuntu based live cd, connect it via USB and assemble the raid 1. See if tt shows different outputs. See https://www.synology.com/en-global/knowledgebase/DSM/tutorial/Storage/How_can_I_recover_data_from_my_DiskStation_using_a_PC

#8

Hey got it working on ubuntu under virtualbox. Thanks Nixcraft :slight_smile:

#9

Glad it worked out. To avoid such issue make sure you backup all important data of your Synology to external USB disk or cloud server. That way you will remain calm and safe.

#10

I have similar issue with my Synology DS213J. Question on assembling the raid: i have two 2TB disks, mirrored; do I need to connect both via usb? How to do you assemble the raid?

Thanks