How to make wget cron not create any text file but still mailto to admin

I have setup cron job through wget, every time when cron gets hit it creates a txt file. As I know this is behaviour of wget. I can stop it by outputting it to null. But when outputting it to null the email stops working. I still need the cron email to come up. Any work around this problem?

Try passing the -q or --quiet to the wget to turn off Wget’s output. For example:

wget -q some_url_here

Try out. If this doesn’t work post your script or wget command.


Linux sysadmin blog - Linux/Unix Howtos and Tutorials - Linux bash shell scripting wiki