Hardwired printer, connected to debian bullseye, fails

I have a Brother MFC-L2700DW printer. It’s worked in the past. I did a full new install of the latest bullseye debian, downloaded the brother linux print driver install script “linux-brprinter-installer-2.2.3-1” and ran it, with seemingly good results but any test page, or print attempts, merely create another pending print job, along with the notice, “Waiting for printer to become available.”

from dmesg: [5.888492] lp: driver loaded but no devices found
but I have found info on this dev and created a rules file: /etc/udev/rules.d/10-usbprinter.rules containing the line:
ATTR{idVendor}==“1d6b”, ATTR{idProduct}==“0001”, MODE:=“0660”, GROUP:=“lp”

it didn’t help so I moved it out of the rules.d dir

Removing core file will not help. Is your printer reported as supported by the linux-brprinter-installer-2.2.3-1 driver? Typically I add printer from settings instead of driver and it worked so far both USB and network printers.

Yes, this installation script supports my printer. Typically setup works for printer install? Wow, never has for me, but I don’t purchase postscript printers. Anyway I need to somehow test whether the cable is working.


Linux sysadmin blog - Linux/Unix Howtos and Tutorials - Linux bash shell scripting wiki