Error: failed retrieving file from mirrors: Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds

Any idea why I am getting this error when I type pacman -Syu?

error: failed retrieving file 'glib2-2.72.3-3-x86_64.pkg.tar.zst' from mirrors.kernel.org : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
:: Synchronizing package databases...
 core                  156.2 KiB   101 KiB/s 00:02 [######################] 100%
 extra                1844.6 KiB  1488 KiB/s 00:01 [######################] 100%
 community               6.9 MiB  6.64 MiB/s 00:01 [######################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (26) archlinux-keyring-20220831-1  cloud-init-22.3.1-1  curl-7.85.0-1  file-5.42-2  glib2-2.72.3-3  gnupg-2.2.39-1  grub-2:2.06.r322.gd9b4638c5-4  less-1:608-1  libnghttp2-1.49.0-1  libxml2-2.10.2-2  linux-5.19.6.arch1-1  linux-firmware-20220815.8413c63-1
              linux-firmware-whence-20220815.8413c63-1  linux-lts-5.15.64-1  lz4-1:1.9.4-1  pcre-8.45-2  python-importlib-metadata-4.8.3-1  python-jsonschema-4.15.0-1  python-nspektr-0.4.0-2  python-ordered-set-4.1.0-1  python-pydantic-1.10.1-1  python-setuptools-1:62.3.4-1
              python-trove-classifiers-2022.8.31-1  python-validate-pyproject-0.10.1-1  vim-9.0.0354-1  vim-runtime-9.0.0354-1

Total Download Size:   485.37 MiB
Total Installed Size:  611.34 MiB
Net Upgrade Size:        2.26 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 linux-5.19.6.arch1-1-x86_64                                                                                                                  178.0 MiB  13.3 MiB/s 00:13 [#########################################################################################################] 100%
 linux-firmware-20220815.8413c63-1-any                                                                                                        146.3 MiB  12.5 MiB/s 00:12 [#########################################################################################################] 100%
 linux-lts-5.15.64-1-x86_64                                                                                                                   130.9 MiB  13.8 MiB/s 00:09 [#########################################################################################################] 100%
 vim-runtime-9.0.0354-1-x86_64                                                                                                                  6.9 MiB  6.01 MiB/s 00:01 [#########################################################################################################] 100%
 grub-2:2.06.r322.gd9b4638c5-4-x86_64                                                                                                           6.8 MiB  8.59 MiB/s 00:01 [#########################################################################################################] 100%
 glib2-2.72.3-3-x86_64.pkg.tar.zst failed to download
 Total ( 6/26)                                                                                                                                485.4 MiB  10.2 MiB/s 00:47 [#########################################################################################################] 100%
error: failed retrieving file 'glib2-2.72.3-3-x86_64.pkg.tar.zst' from mirrors.kernel.org : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

I re-run the same command and it worked again:

pacman -Syu

I think some network problem caused it. :smiling_face_with_tear:

Yes, definitely networking problem for sure.