Boot failure - after troubleshooting advice


This is a follow-on from the previous thread

Although the rear recovery environment worked initially, on a subsequent test restore, the recovery environment failed to load.

I have tried connecting the USB disk to a working system and using gparted to check the partition on the EFI Partition. Unfortunately, this didn’t make any difference.

This is what I’m seeing when the startup fails

Any thoughts?


I have found this

But not sure how I get to a position where I can try this

I’ve also tried playing around with grub

ls (hd0,gpt1)/efi/boot

displays the following files
BOOTX64.efi kernel initrd.cgz grub.cfg

I’ve worked this out

  • the boot partition needs to be fat, rather than fat32
  • use rear mkrescue
  • can only have one disk attached to the system when using rear mkrescue

I battled with the same boot partition issues. I now made hard partition copys of boot partition and copy it over when I want to do a custom install, as the process of creating a boot partition during a custom install is almost never accepted by the installer later on never mind how well you create and format it.
By making a partition copy with gparted, it always works off the bat as it is formatted correctly and has the exact correct size.
Saves me hours.