Black Screen - Booting issue: Ubuntu 18.0.4

I have a multi-partition dual boot device, with two ubuntu distros and versions. Until recently, this unit was fully functional. However, I am seeing a black screen upon booting for the Ubuntu 18.0.4 partition, though the other Kubuntu 20.0.4 partition is fully functional. From my end, I tried to include nomodeset to the grub for the partition showing the issue and also tried boot repair to the repair the grub without success.

Any suggestion with clear steps, if possible, to address this issue would be appreciated.

Are you using Nvidia drivers?

@nixcraft: thanks for jumping in. Yes, it appears to be the issue, though there were other issues in this case, which I already have addressed.

Anyways, taking time into consideration, I took a resolution that appears to be working now. Please see the following thread for more details:

Also, these upgrades and permanent redirect settings for SSL has impacted the ISPConfig control panel. Now, the login page is showing a 404 error. Any suggestions to fix this issue would be appreciated. There is another thread started for this one.

Good week!! :smiley: