Apple Mighty Mouse bindings

Trivial issue that is becoming a problem.

I have a problem using apple Mighty mouse with Linux in XFCE.
It does show Mistsumi Apple mouse in “Mouse and Touchpad” and it is activated.

The problem is that I cannot drag links with the mouse.
I tried to configure what I know in the config files but it didnt help.
If anyone solved a similar problem let me know.

cat /proc/version

Linux version 4.19.0-5-amd64 (stevep@mxlinux.org) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1)) #1 SMP Debian 4.19.37-2~mx17+2 (2019-06-18)

cat /etc/release

NAME=“MX”
VERSION=“18 (Continuum)”
ID=“mx”
VERSION_ID=“18”
PRETTY_NAME=“MX 18 (Continuum)”
ANSI_COLOR=“0;34”
HOME_URL=“https://mxlinux.org
BUG_REPORT_URL=“https://mxlinux.org
PRETTY_NAME=“MX 18.3 Continuum”
DISTRIB_ID=MX
DISTRIB_RELEASE=18.3
DISTRIB_CODENAME=Continuum
DISTRIB_DESCRIPTION=“MX 18.3 Continuum”
PRETTY_NAME=“Debian GNU/Linux 9 (stretch)”
NAME=“Debian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”
ID=debian
HOME_URL=“https://www.debian.org/
SUPPORT_URL=“https://www.debian.org/support
BUG_REPORT_URL=“https://bugs.debian.org/

xfce4-panel --version

xfce4-panel 4.12.1 (Xfce 4.12)

Typically Apple mouse is hard to get work.

Hi Nixcraft.
Can you believe it… The problem just resolved itself like …magic.
I can now drag everything around.
Maybe that is why its called a magic mouse.

There were no updates, no software installed… I am baffled.

I guess in fairness to others and space and triviality of the question, I must delete the question as there was an annoying problem for very long… which just by miracle resolved itself.

Maybe the solution is to whisper to the mouse
“Nixcraft says Typically Apple mouse is hard to get work.”
and then it will work lol!

Update.
I didnt want something trivial like this look like magic and know lots of people have trouble with mighty mouse on linux, so I went through my logs to try and explain why it suddenly works.
(Note: the mighty mouse will work out of the box without the correct config but will not drag and drop.)

It seems like you have to go on e.g. xfce==>Mouse And Touchpad ==> Devices==> then search for apple mouse, click on it and select “Enable this Device”

I did all that originally and it still didnt want to drag and drop.
My logs does tell me that the server rebooted due to a power failure (which I was not aware of) after which the mouse then worked.

So in short, it seems that (at least in XFCE) the mighty mouse only drags-and-drops after you did the config as above, but then reboot after which it will drag and drop - very unUnix but it is what it is.

I expect that merely logging out and logging in or restarting Xorg will also give the same solution, as Xorg partially handles the mouse so it is expected.
But I could not test it the latter.

So at least the mystery is resolved … I hope.


Linux sysadmin blog - Linux/Unix Howtos and Tutorials - Linux bash shell scripting wiki